linux-mips
[Top] [All Lists]

ls from fileutils-4.0.43 segfaults

To: linux-mips@oss.sgi.com, debian-mips@lists.debian.org
Subject: ls from fileutils-4.0.43 segfaults
From: Karsten Merker <karsten@excalibur.cologne.de>
Date: Sun, 22 Apr 2001 22:40:18 +0200
Mail-followup-to: linux-mips@oss.sgi.com, debian-mips@lists.debian.org
Sender: owner-linux-mips@oss.sgi.com
Hallo everyone,

I have tried to install fileutils_4.0.43-1_mipsel.deb from
source.rfc822.org and found that "ls" segfaults, the other binaries seem
to be ok. So I have tried compiling it myself against glibc-2.2.2 on
repeat.rfc822.org and also on my DECstation, but the effect stays the
same.

On repeat we have:
bash> ld -v
GNU ld version 2.11.90.0.1 (with BFD 2.11.90.0.1)
bash> gcc -v
gcc version 2.95.3 20010315 (Debian release)

On my DECstation I have:
bash> ld -v
GNU ld version 010330 (with BFD 010330)
bash> gcc -v
gcc version 2.95.3 20010315 (Debian release)

Has anybody successfully build fileutils-4.0.43 against glibc-2.2.2?

I had fileutils built ok against glibc-2.0.6 before with 
bash> gcc -v
Reading specs from /usr/lib/gcc-lib/mipsel-linux/egcs-2.90.29/specs
gcc version egcs-2.90.29 980515 (egcs-1.0.3 release)
bash> ld -v
GNU ld version 2.8.1 (with BFD 2.8.1)
(these contain Ralf's patches).

Greetings,
Karsten
-- 
#include <standard_disclaimer>
Nach Paragraph 28 Abs. 3 Bundesdatenschutzgesetz widerspreche ich der Nutzung
oder Uebermittlung meiner Daten fuer Werbezwecke oder fuer die Markt- oder
Meinungsforschung.

<Prev in Thread] Current Thread [Next in Thread>