linux-mips
[Top] [All Lists]

current cvs kernel doesn't work with egcs 1.1.2/binutils 2.8.1

To: linux-mips@oss.sgi.com
Subject: current cvs kernel doesn't work with egcs 1.1.2/binutils 2.8.1
From: Guido Guenther <guido.guenther@gmx.net>
Date: Sun, 25 Mar 2001 23:06:08 +0200
Mail-followup-to: linux-mips@oss.sgi.com
Sender: owner-linux-mips@oss.sgi.com
User-agent: Mutt/1.2.5i
it fails with an unaligned access in emulate_load_store_insn (368)
on an Indy/R4600 while doing:
 kmem_cache_create -> down -> __down -> add_wait_queue 
 -> __add_wait_queue -> list_add -> __list_add
it works with the gcc 3.0/binutils 2.11.90 from oss though.
 -- Guido

<Prev in Thread] Current Thread [Next in Thread>
  • current cvs kernel doesn't work with egcs 1.1.2/binutils 2.8.1, Guido Guenther <=