linux-mips
[Top] [All Lists]

RE: Recommended toolchain

To: "'linux-mips@oss.sgi.com'" <linux-mips@oss.sgi.com>
Subject: RE: Recommended toolchain
From: Phil Thompson <Phil.Thompson@pace.co.uk>
Date: Wed, 21 Mar 2001 14:00:22 -0000
Sender: owner-linux-mips@oss.sgi.com
So, going back to the original question, what are the recommended versions -
particularly if you are building 2.4.x kernels?

Are the recomendations in the HOWTO out of date? I had to patch va-mips.h
from the egcs RPM and more fixes seem to be needed before I get a kernel
that compiles.

Thanks,
Phil

-----Original Message-----
From: Ralf Baechle [mailto:ralf@oss.sgi.com]
Sent: 20 March 2001 20:37
To: Karel van Houten
Cc: simong@oz.agile.tv; linux-mips@oss.sgi.com
Subject: Re: Recommended toolchain


On Tue, Mar 20, 2001 at 09:12:02PM +0100, Karel van Houten wrote:

> You wrote:
> > Recently I've been working with various version mixes of the gnu tool
> > chain for a mipsel-linux target and settled on a patchy binutils
> > 2.8.1/egcs 1.1.2/glibc 2.0.6 setup. However this lacks the functionality
> > that I would get from a newer toolchain for use with the linux 2.4
> > kernel. As a result, I was wondering if someone could recommend the
> > latest "stable"/recommended toolchain for a mipsel-linux target.
> 
> Well, I'm currently using:
> binutils 2.10.1
> gcc 2.95.3 (with Maciej's patches)
> glibc 2.2.2 (compiled with above toolchain).
> 
> This toolchain works for native compiles on my mipsel box.
> One drawback: I can't compile any kernels with this setup,
> For kernel compiles I use 2.8.1/egcs-2.90.27/glibc-2.0.6.

You MUST use minimum egcs-2.91.66 (1.1.2); older compilers WILL misscompile
kernels.

  Ralf

<Prev in Thread] Current Thread [Next in Thread>