linux-mips
[Top] [All Lists]

Re: build-problems: GNU fileutils 4.01 on mipsel with glibc 2.2.2

To: Karsten Merker <karsten@excalibur.cologne.de>
Subject: Re: build-problems: GNU fileutils 4.01 on mipsel with glibc 2.2.2
From: Ralf Baechle <ralf@oss.sgi.com>
Date: Sun, 4 Mar 2001 23:15:34 +0100
Cc: linux-mips@oss.sgi.com
In-reply-to: <20010304213609.B25825@linuxtag.org>; from karsten@excalibur.cologne.de on Sun, Mar 04, 2001 at 09:36:09PM +0100
References: <20010304213609.B25825@linuxtag.org>
Sender: owner-linux-mips@oss.sgi.com
User-agent: Mutt/1.2.5i
On Sun, Mar 04, 2001 at 09:36:09PM +0100, Karsten Merker wrote:

> I am trying to get the components for a Debian mipsel-base.tgz built,
> based on glibc-2.2.2. I am working in a chroot()-environment, where I have
> installed glibc 2.2.2, binutils 2.10.91 and gcc 2.95.3 as precompiled
> binaries, all from Maciej's packages (glibc-2.2.2-2.mipsel.rpm,
> gcc-2.95.3-14.mipsel.rpm, binutils-2.10.91-1.mipsel.rpm plus devel and
> dependency packages). Gawk and perl are self-compiled inside the
> chroot()-environment. When trying to compile fileutils, the ./configure
> starts ok, but when coming to "checking for working mktime..." the script
> just hangs forever, and according to top there is nothing consuming CPU
> time (except for top itself). Compiling the fileutils on the "host
> system", i.e. outside the chroot()-environment using egcs-1.0.3a and
> glibc-2.0.6 the problem does not appear. Can anybody confirm this on
> another system? Any ideas what can be the reason for this?

Does you chroot environment have a mounted /proc filesystem?  In the past
we had obscure libc bugs which were triggered when /proc were not
mounted.

  Ralf

<Prev in Thread] Current Thread [Next in Thread>