linux-mips
[Top] [All Lists]

RE: Building XFree86 4.0.2?

To: "'Guido Guenther'" <guido.guenther@uni-konstanz.de>
Subject: RE: Building XFree86 4.0.2?
From: Calvine Chew <calvine@sgi.com>
Date: Thu, 1 Feb 2001 14:55:28 +0800
Cc: "'linux-mips'" <linux-mips@oss.sgi.com>
Sender: owner-linux-mips@oss.sgi.com
Thanks Guido. Do I need to patch rpm too? Will glibc 2.0.6-7 do or do I need
2.1.95?

Regards...

--
Calvine Chew, Technical Consultant
Technology & Industry Consulting Group (Asia South), SGI.
***************************************************************
Inter spem curamque, timores inter et iras, omnem crede diem tibi
diluxisse supremum: grata superveniet quae sperabitur hora.
http://calvine
***************************************************************





> -----Original Message-----
> From: Guido Guenther [mailto:guido.guenther@uni-konstanz.de]
> Sent: Wednesday, January 31, 2001 6:15 PM
> To: Calvine Chew
> Cc: 'linux-mips'
> Subject: Re: Building XFree86 4.0.2?
> 
> 
> On Wed, Jan 31, 2001 at 02:20:17PM +0800, Calvine Chew wrote:
> > I'm trying to build XFree86 4.0.2 on HardHat 5.1 
> (unpatched) and I'm looking
> > at the Mips.cf, which mentions a bootstrapcflag, but the 
> relnotes say
> > supported configs don't need bootstrapcflag="-DMips" passed 
> to make. If I
> > pass bootstrap I get a conflict on stdio.h early on 
> (conflicting type
> > sys_errlist), whereas if I don't pass bootstrapcflag, I get 
> an error around
> > after 5000 lines of output (undefined references to 
> __libc_accept, etc, from
> > libpthread.so when trying to make makekeys.c).
> I'm running 4.0.2 on glib2.0.6 fine here. There are updated glibc2.0
> rpms on oss.sgi.com/mips. With them you can build 4.0.2 
> without any need
> to pass additional flags.
>  -- Guido
> 

<Prev in Thread] Current Thread [Next in Thread>