linux-mips
[Top] [All Lists]

Re: FATAL: cannot determine library version

To: Pete Popov <ppopov@mvista.com>
Subject: Re: FATAL: cannot determine library version
From: Ralf Baechle <ralf@oss.sgi.com>
Date: Sat, 28 Oct 2000 15:18:09 +0200
Cc: "linux-mips@oss.sgi.com" <linux-mips@oss.sgi.com>
In-reply-to: <39F9B924.97AF7A4@mvista.com>; from ppopov@mvista.com on Fri, Oct 27, 2000 at 10:19:32AM -0700
References: <39F9B924.97AF7A4@mvista.com>
Sender: owner-linux-mips@oss.sgi.com
On Fri, Oct 27, 2000 at 10:19:32AM -0700, Pete Popov wrote:

> I've got a big endian kernel running for a new embedded board, and it
> mounts the root fs over nfs.  I'm using the simple-0.2b packages as the
> root fs.  At some point after /bin/sh is loaded, I get the following
> error:
> 
> FATAL: cannot determine library version
> 
> The same root file system is fine on my Indigo2.

Seems your kernel is foobared.  On startup libc is trying to determine
the kernel version but both using uname and /proc/sys/kernel/osrelease
fail for some reason.

  Ralf

<Prev in Thread] Current Thread [Next in Thread>