linux-mips
[Top] [All Lists]

Re: problems with insmod ...

To: Jun Sun <jsun@mvista.com>
Subject: Re: problems with insmod ...
From: Keith Owens <kaos@melbourne.sgi.com>
Date: Sat, 21 Oct 2000 15:12:19 +1100
Cc: linux-mips@oss.sgi.com
In-reply-to: Your message of "Fri, 20 Oct 2000 19:50:03 PDT." <39F1045B.21EF1851@mvista.com>
Sender: owner-linux-mips@oss.sgi.com
On Fri, 20 Oct 2000 19:50:03 -0700, 
Jun Sun <jsun@mvista.com> wrote:
>I am using modutils v2.1.121, generated by binutils 2.8.1/egcs
>v1.0.3a/glibc 2.0.6.
>
>BTW, I seem to remember someone said the modutils 2.1.121 is not good
>MIPS.  Which version is good?

2.1.121 is over two years old and is missing several mips patches.
There is no good reason to use 2.1.121, modutils 2.3 is backwards
compatible.

The last mips specific patch was in modutils 2.3.15.  2.3.18 ignores
empty relocate sections which I believe were a problem for several
architectures, possibly including mips.  2.3.19 will be released this
weekend and includes a mips patch to fix a minor problem which I doubt
anybody has ever hit.  If you need modutils now, use 2.3.18, if you can
wait 48 hours, wait for 2.3.19.

ftp://ftp.<country>.kernel.org/pub/linux/kernel/utils/modutils/v2.3.


<Prev in Thread] Current Thread [Next in Thread>