[Top] [All Lists]

Re: libc upgrade

To: "Gleb O. Raiko" <>
Subject: Re: libc upgrade
From: Keith M Wesolowski <>
Date: Tue, 26 Sep 2000 10:48:05 -0700
In-reply-to: <>; from on Tue, Sep 26, 2000 at 12:37:57PM +0400
References: <> <> <> <> <> <> <>
User-agent: Mutt/1.2i
On Tue, Sep 26, 2000 at 12:37:57PM +0400, Gleb O. Raiko wrote:

> Well, another question. Ralf uploaded cross tools rpms year ago. Does
> anybody have native rmps for big endian ? Also, does anybody have cross
> tools for sparc glibc 2.1 (RH6.x sparc distribution) ? I can't compile
> cross gcc on my Ultra, it seems like a bug in the sparc compiler, the
> process fails in parsing an enum decl in a header.

Native rpms, no. Native tarballs that "work," yes. I do have cross
tools (again, not RPMs) for sparc glibc 2.1 - it's my main devel
environment. I also have a script that builds an entire cross
toolchain and kernel for any versions of gcc/binutils/glibc/kernel
that you supply, and it's tested mainly on sparc glibc 2.1. I have not
yet had any problems building such a cross toolchain, with a mainly
stock RH6.2 system (make has to be upgraded to build recent
glibc). Information on how I'm doing this is at I recommend using the
make-cross tools, however, located at HTH.

Keith M Wesolowski            
University of Nevada          
Chemistry Department Systems and Network Administrator

<Prev in Thread] Current Thread [Next in Thread>