[Top] [All Lists]

Re: GLIBC 2.2 should work on MIPS-Linux

Subject: Re: GLIBC 2.2 should work on MIPS-Linux
From: Andreas Jaeger <>
Date: 21 Apr 2000 14:59:30 -0700
In-reply-to: Andreas Jaeger's message of "21 Apr 2000 10:30:21 -0700"
References: <>
User-agent: Gnus/5.0804 (Gnus v5.8.4) XEmacs/21.1 (Bryce Canyon)
One more WARNING if you're going to use glibc 2.2:
As long as glibc 2.2 is not released the glibc developers
might make incompatible changes so that different snapshosts might not
be compatible to each other.

I will try to maintain compatibility with glibc 2.0.x - but not
between different glibc 2.2 snapshots.

But a problem is gcc:

gcc 2.96 might (the patch is not approved yet) even contain an
incompatible ABI change in gcc (see
<>) and I don't
see a way to work around this for now.  Ok, this is only relevant if
you're passing va_lists around (for example if you use vprintf) but
all those programs and libraries might need to recompiled.:-(

Please remember this if you're using bleeding edge compilers and glibc
- and use them at your own risk.

 Andreas Jaeger
  SuSE Labs

<Prev in Thread] Current Thread [Next in Thread>