linux-mips-fnet
[Top] [All Lists]

RE: -fno-strict-aliasing problem in the latest 2.3

To: Harald Koerfgen <Harald.Koerfgen@home.ivm.de>
Subject: RE: -fno-strict-aliasing problem in the latest 2.3
From: Geert Uytterhoeven <Geert.Uytterhoeven@sonycom.com>
Date: Thu, 17 Feb 2000 13:20:31 +0100 (MET)
Cc: "Gleb O. Raiko" <raiko@niisi.msk.ru>, linux-mips@fnet.fr, SGI Linux <linux@cthulhu.engr.sgi.com>
In-reply-to: <XFMail.000216190319.Harald.Koerfgen@home.ivm.de>
Sender: geert@sonycom.com
On Wed, 16 Feb 2000, Harald Koerfgen wrote:
> On 15-Feb-00 Gleb O. Raiko wrote:
> > There is a problem with the way main Makefile determines whether the
> > compiler suports -fno-strict-aliasing. Namely, Makefile blindly gets $CC
> > and tries to feed this option to it. Unfortunately, we set CC to proper
> > mips[el]-linux-gcc later in arch/mips/Makefile, so the main Makefile
> > just checks against native gcc. On RH6.1 with latest cross tool rpms
> > installed, I get cc1: Invalid option `-fno-strict-aliasing' during
> > comppilation, obviously.
> 
> I am not exactly shure if it has ill side effects or if this may not be wanted
> for some reason, but the attached patch fixes that for me.
> 
> OK to commit?

Apart from the fact that your mailer breaks long line, even in attachments, it
seems to work fine.

Gr{oetje,eeting}s,

                                                Geert

--
Geert Uytterhoeven ------------- Sony Software Development Center Europe (SDCE)
Geert.Uytterhoeven@sonycom.com ------------------- Sint-Stevens-Woluwestraat 55
Voice +32-2-7248638 Fax +32-2-7262686 ---------------- B-1130 Brussels, Belgium

<Prev in Thread] Current Thread [Next in Thread>