[Top] [All Lists]

RE: -fno-strict-aliasing problem in the latest 2.3

To: "Gleb O. Raiko" <>
Subject: RE: -fno-strict-aliasing problem in the latest 2.3
From: Harald Koerfgen <>
Date: Wed, 16 Feb 2000 19:03:19 +0100 (MET)
Cc:, SGI Linux <>
In-reply-to: <>
Organization: none
Reply-to: "Harald Koerfgen" <>

On 15-Feb-00 Gleb O. Raiko wrote:
> There is a problem with the way main Makefile determines whether the
> compiler suports -fno-strict-aliasing. Namely, Makefile blindly gets $CC
> and tries to feed this option to it. Unfortunately, we set CC to proper
> mips[el]-linux-gcc later in arch/mips/Makefile, so the main Makefile
> just checks against native gcc. On RH6.1 with latest cross tool rpms
> installed, I get cc1: Invalid option `-fno-strict-aliasing' during
> comppilation, obviously.

I am not exactly shure if it has ill side effects or if this may not be wanted
for some reason, but the attached patch fixes that for me.

OK to commit?

Attachment: Makefile-patch
Description: Makefile-patch

<Prev in Thread] Current Thread [Next in Thread>