linux-mips-fnet
[Top] [All Lists]

Re: glibc build problems, mipsel glibc 2.0.7-981211

To: Florian Lohoff <flo@rfc822.org>
Subject: Re: glibc build problems, mipsel glibc 2.0.7-981211
From: Andreas Jaeger <aj@suse.de>
Date: 28 Oct 1999 16:22:34 +0200
Cc: linux@engr.sgi.com, linux-mips@fnet.fr, linux-mips@vger.rutgers.edu, debian-mips@lists.debian.org
In-reply-to: Florian Lohoff's message of "Thu, 28 Oct 1999 15:43:32 +0200"
References: <19991028154332.A1971@paradigm.rfc822.org>
Sender: aj@suse.de
User-agent: Gnus/5.070096 (Pterodactyl Gnus v0.96) XEmacs/21.1 (Biscayne)
>>>>> Florian Lohoff writes:

 > Hi,
 > i discover the following problems while trying to build the debian
 > glibc package from slink (2.0.7.981211 + mips patches)



 > /data/glibc/glibc-2.0.7.19981211/build-mipsel/time/zic -d
 >      /data/glibc/glibc-2.0.7.19981211/debian/install/usr/share/zoneinfo -L
 >      /dev/null -y ./yearistype africa

 > /data/glibc/glibc-2.0.7.19981211/build-mipsel/time/zic: error in loading
 >      shared libraries: undefined symbol: __deregister_frame_info
Please read the glibc FAQ
2.8.    When I run an executable on one system which I compiled on
        another, I get dynamic linker errors.  Both systems have the same
        version of glibc installed.  What's wrong?

Question 2.8 is most likely not in 2.0.7 - get the current FAQ via
http://sourceware.cygnus.com/glibc


 > Ok - I found the symbol ... But .. LD_PRELOAD doesnt seem to help ...


 > (root@repeat)/data/glibc/glibc-2.0.7.19981211/build-mipsel/time# objdump
 >      --syms /data/glibc/glibc-2.0.7.19981211/build-mipsel/elf/ld.so.1 |
 >      grep dl_unload

 > (root@repeat)/data/glibc/glibc-2.0.7.19981211/build-mipsel/time# export
 >      LD_PRELOAD="/data/glibc/glibc-2.0.7.19981211/build-mipsel/elf/ld.so.1
 >      /data/glibc/glibc-2.0.7.19981211/build-mipsel/libc.so"

 > (root@repeat)/data/glibc/glibc-2.0.7.19981211/build-mipsel/time#
 >      /data/glibc/glibc-2.0.7.19981211/build-mipsel/time/zic -d
 >      /data/glibc/glibc-2.0.7.19981211/debian/install/usr/share/zoneinfo -L
 >      /dev/null -y ./yearistype africa

 > Segmentation fault
don't try to build the files for now - the problem you encounter is
one of the reasons why 2.0.7 was never released officially.

 > I am not sure if i am able to preload ld.so.1 - I suspect not ....
No.
 > What do i do now ? Compile a "zic" whithout the dependency, 
 > build the package and replace the libc/ld.so ? This seems to be a little
 > risky.
Build without time, install with `make install_prefix=/tmp/glibc
install' and check if everything runs (compare with question 3.18 of
the FAQ).

For more details, just ask;-)
Andreas

P.S. you missed to include all glibc lists ;-)
-- 
 Andreas Jaeger   
  SuSE Labs aj@suse.de  
   private aj@arthur.rhein-neckar.de

<Prev in Thread] Current Thread [Next in Thread>