[Top] [All Lists]

RE: login problems again ... (DS 5000)

Subject: RE: login problems again ... (DS 5000)
From: Dave Airlie <>
Date: Tue, 11 May 1999 20:47:41 +0100 (IST)
In-reply-to: <>
Right I got a login compiled that works, it's not the standard util-linux
login binary, so maybe someone can put this as a question in a HOWTO or

-- cut--here---
x.x Login doesn't work?

There is some really wierd problems with login on the standard NFS root
system. This can sometimes be solved by re-compiling the login binary from
the util-linux SRPM from the FTP site, if this doesn't
work for you grab, the SimplePAMApps package from

Do a
./configure --without-pniam --without-pwdb

Make will stop somewhere in the su subdir with errors, then do

cd pamapps/login
cp login /bin/login
chmod u+s 4711 /bin/login

-- and here---

And tada your login binary should work ...


On Tue, 11 May 1999, Harald Koerfgen wrote:

> Hi,
> On 11-May-99 Dave Airlie wrote:
> > 
> > I'm giving up on trying to track that login bug down, it's very wierd is
> > all I can say, just some things I've noticed while looking for it..
> If anything else fails, I'll try to reproduce how I got this working for
> my /133. Sorry, but I can't remember how I did it.
> ---
> Regards,
> Harald

------------ David Airlie,,airlied@skynet --------
Telecommunications Research Centre, ECE Dept, University of Limerick \   -- Telecommunications Researcher      \
--- TEL: +353-61-202695 -----------------------------------------------

<Prev in Thread] Current Thread [Next in Thread>