[Top] [All Lists]

Re: Boot success/root-nfs

Subject: Re: Boot success/root-nfs
From: Florian Lohoff <>
Date: Sat, 2 Jan 1999 12:59:39 +0100
In-reply-to: <>; from Harald Koerfgen on Sat, Jan 02, 1999 at 09:36:35AM +0100
References: <> <>
On Sat, Jan 02, 1999 at 09:36:35AM +0100, Harald Koerfgen wrote:
> As I've said, I wouldn't call 0.007 rock-solid, but, hey, we're hacking
> aren't we?


> > Anotherone is that the kernel is unable to find an initial console
> > until you link /dev/console -> /dev/ttyS2 (for me) ...
> Sorry, forgot to mention, you have to change /dev/console and /dev/tty
> according to linux/Documentation/serial-console.txt.

The "Unable to open initial console" helped a lot :)

> Florian, declance.c doesn't work on my '260, so I'd like to ask you a few
> R4000 related questions:

It doesnt work on my /240 either ... It sends out packages and
it gets the FIRST but no others - It receives the BOOTP request answer
correct but the tcpdump output shows that it trys to ask my
sunrpc for the port numbers for the mountd/nfsd which my machine
answers but it doesnt seem to creep up the Kernel.

> o How long does it take for init to start? It takes several _minutes_ on
> my '133 and tcpdump doesn't show any activity on the wire.

Yup multiple minutes ...

> o Can you switch the runlevel? Doesn't work on my '133, machine hangs
> completely.

It looks like it does - It boots into and then shows me a change to
3 and trys then to start a mingetty on /dev/ttyS2 which doesnt seem to work :)

> o Does mount work with a vanilla /bin/mount? It didn't on my '133. This is
> no big deal. Replacing /bin/mount with an rpm from
> _did_ work.

It does ... I tried to replace the init by the one on CobaltMicro
but that doesnt help so - What on earth is the init doing ?

Florian Lohoff                  +49-5241-470566
Good, Fast, Cheap: Pick any two (you can't have all three).  (RFC 1925)

<Prev in Thread] Current Thread [Next in Thread>