linux-mips-fnet
[Top] [All Lists]

Re: RM200

To: linux-mips@fnet.fr
Subject: Re: RM200
From: Aleksandr Konstantinov <akonstantinov@yahoo.com>
Date: Tue, 22 Dec 1998 04:19:46 -0800 (PST)

    Hello



---Michael Engel <engel@math.uni-siegen.de> wrote:

> >  I'm still trying to run linux on SNI RM200 (ISA bus).  
> >  I've got si_to_nt firmware and installed it. NT runs OK. 
> >  I tried to run milo + vmlinux from vmlinux-rm200-2.1.56.tar.gz .
> > 
> >   Milo writes 
> > 
> > Linux/MIPS ARC Bootstrap Loader
> > Copyright (C) Waldorf Electronics and others 1994, 1995, 1996
> > 
> > And nothing about system detected. After 5 minutes
> > it says 
> > 
> > Launching Kernel...
> >   
> >  and everything hangs.
> 
> You need to modify MILO 0.27.1 to properly detect the RM200 ISA.
> The ARC firmware in the RM200 loads the kernel with a 8 byte offset to
> what is expected (bug, bug ;-)), so the ARC bootloader jump to the
wrong 
> address. Btw., you should specify the "-v" flag to milo to get some
nice
> output about what the ARC console thinks the system is :).
> 
> I put the modified milo 0.27.1 and pandora on  
> ftp://ftp.unix-ag.org/pub/os/linux/mips/rm200/
> - just give it a try !
> 
> I can build a kernel for the RM200 ISA later, it's currently in a
big tar.gz
> file as I ran out of disk space ...


  Thanks. MILO loaded fine. Kernel started but hung
after

  Probing PCI hardware
  Calibrating delay loop 

 
 Are You using any patches to build kernel, or just
CONFIG_PCI=n
   Could You give me some hints, I'm not experienced
enough.

  I could build it here (there is  x86 linux box here
and I took cross compiler from ftp.fnet.fr )


   Sincerely

    Aleksandr Konstantinov

_________________________________________________________
DO YOU YAHOO!?
Get your free @yahoo.com address at http://mail.yahoo.com

<Prev in Thread] Current Thread [Next in Thread>