linux-mips-fnet
[Top] [All Lists]

Re: Problems building 2.1.121-r3000

To: linux-mips@fnet.fr
Subject: Re: Problems building 2.1.121-r3000
From: Richard van den Berg <R.vandenBerg@inter.NL.net>
Date: Tue, 20 Oct 1998 15:42:10 +0200 (MET DST)
In-reply-to: <199810201058.LAA00144@molnir.demon.co.uk>
On Tue, 20 Oct 1998, Matt Foster wrote:

> > For which machine are you trying to compile a kernel?
> Decstation 5000/25 (Personal)

That's easy, I've one too.

> binutils2.8.1 and gcc 2.7.2 from the decstation website.
> Below is .config

That's allright too, I've attached a diff of your config against mine. You
should boot with `boot 3/tftp root=/dev/ram`. If you want to play with
networking code remove initrd and enable nfsroot + bootp (easiest done
with `make menuconfig` and boot with `boot 3/tftp root=/dev/nfs`. 

Have fun.

Regards,
Richard

2c2
< # Automatically generated make config: don't edit
---
> # Automatically generated by make menuconfig: don't edit
8c8
< # CONFIG_EXPERIMENTAL is not set
---
> CONFIG_EXPERIMENTAL=y
13a14,16
> # CONFIG_ALGOR_P4032 is not set
> # CONFIG_BAGET_MIPS is not set
> CONFIG_DECSTATION=y
38a42
> # CONFIG_BINFMT_JAVA is not set
43d46
< # CONFIG_PARPORT is not set
51c54
< # Block devices
---
> # Frame Buffer support
53,54c56
< # CONFIG_BLK_DEV_FD is not set
< CONFIG_BLK_DEV_IDE=y
---
> # CONFIG_FB is not set
57c59
< # Please see Documentation/ide.txt for help/info on IDE drives
---
> # TURBOchannel support
59,66c61
< # CONFIG_BLK_DEV_HD_IDE is not set
< # CONFIG_BLK_DEV_IDEDISK is not set
< # CONFIG_BLK_DEV_IDECD is not set
< # CONFIG_BLK_DEV_IDETAPE is not set
< # CONFIG_BLK_DEV_IDEFLOPPY is not set
< # CONFIG_BLK_DEV_IDESCSI is not set
< # CONFIG_BLK_DEV_CMD640 is not set
< # CONFIG_IDE_CHIPSETS is not set
---
> CONFIG_TC=y
69c64
< # Additional Block Devices
---
> # Block devices
70a66,68
> # CONFIG_BLK_DEV_FD is not set
> # CONFIG_BLK_DEV_IDE is not set
> # CONFIG_BLK_DEV_HD_ONLY is not set
75c73
< # CONFIG_BLK_DEV_INITRD is not set
---
> CONFIG_BLK_DEV_INITRD=y
84,87c82,83
< CONFIG_PACKET=y
< CONFIG_NETLINK=y
< # CONFIG_RTNETLINK is not set
< # CONFIG_NETLINK_DEV is not set
---
> # CONFIG_PACKET is not set
> # CONFIG_NETLINK is not set
101,104d96
< 
< #
< # (it is safe to leave these untouched)
< #
108,111c100
< 
< #
< #  
< #
---
> # CONFIG_IPV6 is not set
113a103,112
> # CONFIG_X25 is not set
> # CONFIG_LAPB is not set
> # CONFIG_BRIDGE is not set
> # CONFIG_LLC is not set
> # CONFIG_ECONET is not set
> # CONFIG_WAN_ROUTER is not set
> # CONFIG_NET_FASTROUTE is not set
> # CONFIG_NET_HW_FLOWCONTROL is not set
> # CONFIG_CPU_IS_SLOW is not set
> # CONFIG_NET_SCHED is not set
118,163c117
< CONFIG_SCSI=y
< 
< #
< # SCSI support type (disk, tape, CD-ROM)
< #
< CONFIG_BLK_DEV_SD=y
< # CONFIG_CHR_DEV_ST is not set
< # CONFIG_BLK_DEV_SR is not set
< # CONFIG_CHR_DEV_SG is not set
< 
< #
< # Some SCSI devices (e.g. CD jukebox) support multiple LUNs
< #
< # CONFIG_SCSI_MULTI_LUN is not set
< CONFIG_SCSI_CONSTANTS=y
< CONFIG_SCSI_LOGGING=y
< 
< #
< # SCSI low-level drivers
< #
< # CONFIG_SCSI_7000FASST is not set
< # CONFIG_SCSI_AHA152X is not set
< # CONFIG_SCSI_AHA1542 is not set
< # CONFIG_SCSI_AHA1740 is not set
< # CONFIG_SCSI_AIC7XXX is not set
< # CONFIG_SCSI_ADVANSYS is not set
< # CONFIG_SCSI_IN2000 is not set
< # CONFIG_SCSI_AM53C974 is not set
< # CONFIG_SCSI_BUSLOGIC is not set
< # CONFIG_SCSI_DTC3280 is not set
< # CONFIG_SCSI_EATA_DMA is not set
< # CONFIG_SCSI_EATA_PIO is not set
< # CONFIG_SCSI_EATA is not set
< # CONFIG_SCSI_FUTURE_DOMAIN is not set
< # CONFIG_SCSI_GDTH is not set
< # CONFIG_SCSI_GENERIC_NCR5380 is not set
< # CONFIG_SCSI_NCR53C406A is not set
< # CONFIG_SCSI_PAS16 is not set
< # CONFIG_SCSI_PCI2000 is not set
< # CONFIG_SCSI_PCI2220I is not set
< # CONFIG_SCSI_PSI240I is not set
< # CONFIG_SCSI_QLOGIC_FAS is not set
< # CONFIG_SCSI_SEAGATE is not set
< # CONFIG_SCSI_T128 is not set
< # CONFIG_SCSI_U14_34F is not set
< # CONFIG_SCSI_ULTRASTOR is not set
---
> # CONFIG_SCSI is not set
169d122
< # CONFIG_ARCNET is not set
171,183d123
< # CONFIG_EQUALIZER is not set
< CONFIG_NET_ETHERNET=y
< # CONFIG_NET_VENDOR_3COM is not set
< # CONFIG_LANCE is not set
< # CONFIG_BAGETLANCE is not set
< # CONFIG_NET_VENDOR_SMC is not set
< # CONFIG_NET_VENDOR_RACAL is not set
< # CONFIG_NET_ISA is not set
< # CONFIG_NET_EISA is not set
< # CONFIG_NET_POCKET is not set
< # CONFIG_FDDI is not set
< # CONFIG_DLCI is not set
< # CONFIG_PPP is not set
185,213c125,126
< # CONFIG_NET_RADIO is not set
< # CONFIG_TR is not set
< # CONFIG_WAN_DRIVERS is not set
< # CONFIG_LAPBETHER is not set
< # CONFIG_X25_ASY is not set
< 
< #
< # AX.25 network device drivers
< #
< # CONFIG_MKISS is not set
< # CONFIG_6PACK is not set
< # CONFIG_BPQETHER is not set
< # CONFIG_DMASCC is not set
< # CONFIG_SCC is not set
< # CONFIG_BAYCOM_SER_FDX is not set
< # CONFIG_BAYCOM_SER_HDX is not set
< # CONFIG_BAYCOM_PAR is not set
< # CONFIG_BAYCOM_EPP is not set
< # CONFIG_SOUNDMODEM is not set
< 
< #
< # ISDN subsystem
< #
< # CONFIG_ISDN is not set
< 
< #
< # CD-ROM drivers (not for SCSI or IDE/ATAPI drives)
< #
< # CONFIG_CD_NO_IDESCSI is not set
---
> # CONFIG_PPP is not set
> CONFIG_DECLANCE=y
216c129
< # Character devices
---
> # DECstation Character devices
218,219c131
< CONFIG_VT=y
< CONFIG_VT_CONSOLE=y
---
> # CONFIG_VT is not set
220a133,134
> # CONFIG_DZ is not set
> CONFIG_ZS=y
222,223c136
< # CONFIG_SERIAL_EXTENDED is not set
< # CONFIG_SERIAL_NONSTANDARD is not set
---
> CONFIG_PROM_CONSOLE=y
224a138
> # CONFIG_KEYBOARD is not set
226,228d139
< # CONFIG_QIC02_TAPE is not set
< # CONFIG_APM is not set
< # CONFIG_WATCHDOG is not set
230,237d140
< # CONFIG_VIDEO_DEV is not set
< # CONFIG_NVRAM is not set
< # CONFIG_JOYSTICK is not set
< 
< #
< # Ftape, the floppy tape device driver
< #
< # CONFIG_FTAPE is not set
243c146
< CONFIG_MINIX_FS=y
---
> # CONFIG_MINIX_FS is not set
264,267c167,170
< CONFIG_UFS_FS=y
< CONFIG_BSD_DISKLABEL=y
< # CONFIG_SMD_DISKLABEL is not set
< # CONFIG_SOLARIS_X86_PARTITION is not set
---
> # CONFIG_UFS_FS is not set
> # CONFIG_EFS_FS is not set
> # CONFIG_ADFS_FS is not set
> # CONFIG_QNX4FS_FS is not set
272,276d174
< # Sound
< #
< # CONFIG_SOUND is not set
< 
< #
282d179
< 
<Prev in Thread] Current Thread [Next in Thread>