linux-mips-fnet
[Top] [All Lists]

Re: Problems booting a 4000SC.

To: linux-mips@fnet.fr
Subject: Re: Problems booting a 4000SC.
From: cdemps@lsumc.edu (Dempsey, Charles)
Date: Thu, 23 Oct 1997 09:46:06 -0600
Organization: LSU Med Ctr
References: <344E3385.23A6@domain.com> <19971022175420.14413@tbird.cobaltmicro.com>
Reply-to: cdemps@lsumc.edu
Ralf Baechle wrote:
> 
> On Wed, Oct 22, 1997 at 11:10:29AM -0600, Charles A. Dempsey wrote:
> > I've got my Magnum 4000SC-50 set up, but I can't get a kernel to boot.

> I suspect we've got still a bug in the handling of the SC/MC caches.
> Hard to fix without having a machine with such a CPU.  Another cache
> problem we have to fix are I/D caches with different line sizes like
> in the Olivetti M700-10.  And we don't handle split I/D level 2
> SC/MC caches correctly, but I so far I don't of any machine using such
> caches.

Comparing the pandora output on the two machines the 4000PC-50 says;

Arc Vendor ID                                                                   
                        :[MIPS MAG]
Arc Product ID                                                                  
                :[00006b8283c0051]
Arc System ID                                                                   
                        :[Microsoft-Jazz]
Arc CPU ID                                                                      
                                                :[Mips R4000 PC]
Processor type                                                                  
                :[R4000PC I04 V3.0]
Primary ICache size                                             :[0x2000]
Primary ICache line size        :[0x0020]
Primary DCache size                                             :[0x2000]
Primary DCache line size        :[0x0010]
Secondary Cache size                                    :[unknown]
Arc System identified as        :Mips Magnum 4000 (Jazz)

The 4000SC-50 says;

Arc Vendor ID                                                                   
                        :[MIPS MAG]
Arc Product ID                                                                  
                :[00006b829034004d]
Arc System ID                                                                   
                        :[Microsoft-Jazz]
Arc CPU ID                                                                      
                                                :[Mips R4000 SC]
Processor type                                                                  
                :[R4000PC I04 V3.0]
Primary ICache size                                             :[0x2000]
Primary ICache line size        :[0x0010]
Primary DCache size                                             :[0x2000]
Primary DCache line size        :[0x0010]
Secondary Cache size                                    :[unknown]
Arc System identified as        :Mips Magnum 4000 (Jazz)

The odd things are;

1. The SC "processor type" is the same as the PC.
2. The cache numbers are the same except for the primary Icache line size, and
3. The secondary cache size is "unknown" in the SC. 

Could this be a boot loader problem? I believe from comparing the floppy disk 
access 
times on the two machines that the kernel loads but the launch fails before 
video 
output begins. How does one determine the failed process in such a case?

Thanks,
Charles

<Prev in Thread] Current Thread [Next in Thread>