linux-mips-fnet
[Top] [All Lists]

Re: Oily report

To: linux-mips@fnet.fr
Subject: Re: Oily report
From: Andreas Busse <andy@soft-n-hard.de>
Date: Mon, 16 Oct 1995 13:33:22 +0100
In-reply-to: <199510161117.NAA15707@bandsept.univ-evry.fr>
Hi all, 

 > well here is where we are, aka State of the art on Oily boxes (I
 > guess):
 > 
 > kernel 1.2.11 boots and mounts a root fs from a 1.44M floppy - yes
 > Andy your floppy driver works out of the box on the Oily - Sonic
 > ethernet chip probing seems ok (good MAC address reported). We had
 > problem linking user binaries ('we' is - as Paolo was in Paris this
 > week-end - Luc, Paolo and me :): when we use mipsel-linux-ld to link
 > things like ash or ifconfig (yes we can dream;) we got an 'undefined
 > reference to _main', but it's solved by putting a '_' in from of main in
 > the source (you should have heard Paolo saying "PUT AN _ IN FRONT OF
 > IT" ;) or more cleany using mipsel-linux-gcc to do the link (Ralf can
 > you light our lantern, please ?) Well at last we got an OMAGIC
 > executable but the kernel panic when we tried to launch it (both ash
 > and ifconfig),... the ash compiled by Ralf works fine,... I need to
 > take a closer look  at this... Anyway, we still got to find out a way
 > to proprely (aka without the NMI stuff) discover of much RAM there is
 > in a Oily box...
 > 

I have no clue what Ralf did to compile ash... However, ifconfig
is really whishful thinking since the SONIC driver is still not
working (shame on me).

 > One more word, I'm still confused by the kernel: each time I try to
 > compile a kernel with the Oily '#ifdef' and 'switch' I had added
 > (surely wrongly), it fails to boot, so for now I use a "standard" MIPS
 > Magnum 4000 configuration !! 

What exactly happens when you boot a kernel configured for the
Olivetti? I might be able to help, but I really need more info.

Oh, BTW: Regarding the keyboard problems: Ralf insists of his 
idea that the keyboard controller is at a different address than
it is currently used. I cannot confirm that since MY keyboard
works fine. There are enough Magnumish people on the list to
find out what's actually wrong, so:

TO ALL MAGNUM OWNERS: Could you please try to boot a kernel
(I provide a binary if necessary) and tell us what happens with
your keyboard? 

Cheers,
Andy


-----------------------------------------------------------
Andreas Busse                      | andy@soft-n-hard.de
Soft N Hard GbR                    | Phone: +49 2636-970105
Im Hufen Boden 16, D-53498 Waldorf | Fax:   +49 2636-970106
-----------------------------------------------------------

<Prev in Thread] Current Thread [Next in Thread>